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COPYRIGHT 

Copyright © 1998-2018. Wilcom Pty Ltd, Wilcom International Pty Ltd. All Rights reserved. 

All title and copyrights in and to Digitizer Embroidery Software (including but not limited to any images, animations, 
text and applications incorporated into the Digitizer Embroidery Software), the accompanying printed materials, 
and any copies of Digitizer Embroidery Software are owned by licensor or its suppliers. The SOFTWARE PRODUCT is 
protected by copyright laws and international treaty provisions. Therefore, you must treat Digitizer Embroidery 
Software like any other copyrighted material. You may not copy the printed materials accompanying Digitizer 
Embroidery Software. 

Portions of the imaging technology of Digitizer Embroidery Software are copyrighted by AccuSoft Corporation. 

Limited warranty 
Except with respect to the REDISTRIBUTABLES, which are provided ‘as is’ without warranty of any kind, Janome 
Sewing Machine Co., Ltd. (hereinafter referred to as ‘jsmc’) warrants that the Software Media and accompanying 
documentation are free from defects in materials and workmanship, and that Digitizer Embroidery Software will 
perform substantially in accordance with the accompanying written materials for a period of ninety (90) days from 
the date of receipt. Some states and jurisdictions do not allow limitations on duration of an implied warranty, so the 
above limitation may not apply to you. To the extent allowed by applicable law, implied warranties on the Digitizer 
Embroidery Software are limited to ninety (90) days. 

Limitation of liability 
jsmc’s liability under the warranty shall be limited to the cost of the Software Media and Documentation. Under no 
circumstances shall jsmc be liable for any consequential, incidental, or indirect damages (including, without 
limitation, damages for loss of business profit, business interruption, loss of business information, or any other 
pecuniary loss) arising out of the use or inability to use the Digitizer Embroidery Software. In no event will jsmc be 
similarly liable to any other party. 

Note 
The screen illustrations in this publication are intended to be representations, not exact duplicates of the screen 
layouts generated by the software. Similarly, design samples are representative of processes and procedures only. 
They may or may not be packaged with your particular version of the software. 

Customer remedies 
jsmc’s and its suppliers’ entire liability and your exclusive remedy shall be, at jsmc’s option, either (a) return of the 
price paid, or (b) repair or replacement of the Digitizer Embroidery Software that does not meet jsmc’s Limited 
Warranty and that is returned to jsmc with a proof of purchase within the warranty period. 

Any replacement Digitizer Embroidery Software will be warranted for the remainder of the original warranty period 
or thirty (30) days, whichever is longer. 
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INTRODUCTION 

The embroidery software supports the automatic and semi-automatic digitizing of both bitmap 
images and vector drawings. The Auto-Digitize toolbox provides tools for the automatic digitizing of 
prepared artwork and photos. Explore the topics listed on the right. 

 

CorelDRAW® also lets you trace bitmaps to convert them to fully editable and scalable vector 
graphics. You can trace scanned sketches, artwork, digital photos, and logos and easily integrate 
them into your designs. 
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AUTO-DIGITIZE EMBROIDERY 

The software can automatically convert artwork to embroidery. Artwork is ‘batch processed’ to 
create the many embroidery objects that make up a design. The software can recognize shapes in 
artwork - bitmap and vector - and choose suitable stitch types to use. It can also determine a 
stitching sequence based on closest join. The auto-digitizing tools become available when an image 
is selected. Only one image can be selected at a time. See also Convert artwork.Auto-digitizing tools 
accept artwork in either a raw or processed state. However, the quality of the resulting designs 
greatly depends on the type and quality of the original artwork. Generally speaking, vector 
drawings preserve the picture quality when resized, whereas bitmap images cause problems of 
pixelation and image degradation when enlarged or scaled down. However, any scaling required 
should be done before importing into the software as the importing operation automatically 
transforms vector drawings into bitmaps. In order to make bitmap images more suitable for 
automatic digitizing, the software also provides image processing capabilities and links to graphics 
packages. See also Artwork. 

Auto-digitize instantly 

 

Use Auto-Digitize > Auto-Digitize Instant Embroidery to create embroidery designs directly from 
imported images using default settings. 

In essence, creating an embroidery design with the Auto-Digitize Instant Embroidery tool is simply a 
matter of selecting the image you want to convert, and clicking the tool. The system automatically 
determines colors to fill, turn into details, or omit altogether. And it chooses the most suitable 
stitch types to apply using default settings. Even if an image is not pre-processed with the image 
preparation tool, Auto-Digitize Instant Embroidery automatically processes and converts it. Delete 
any unwanted background stitching. Edit stitch colors and types as preferred. 

 

You may want to preset the Design Palette according to your available threads before processing 
the image. Select from a wide range of commercial thread charts. You can assign up to 128 color 
slots. 

http://www.embroideryhelp.net/display/WILHPD/Convert+artwork
http://www.embroideryhelp.net/display/WILHPD/Backdrops


 Auto-digitize embroidery 
 
 

 

Digitizer V5.5 User Guide: Auto-Digitizing 23-Apr-18 3 
 

Auto-digitizing artwork 

 

Use Auto-Digitize > Auto-Digitize Embroidery to create embroidery designs directly from 
imported images using conversion settings. 

 

For more control over object conversion, use the Auto-Digitize Embroidery method. This technique 
recognizes shapes in artwork - bitmap or vector - and selects suitable stitch types to use. However, 
it allows more control over conversion settings. To use the feature... 

 Import the artwork. See also Import images. Whether you’re working with bitmap or vector 
graphics, you need to prepare them first: 

o Scan or insert a bitmap image. If you are using a bitmap image as input, it will need to 
be image-processed before conversion. 

o Insert or create a vector graphic. If you are using a vector graphic as input, you can 
remove overlapping objects by ‘merging’ them. This eliminates overlapping stitching 
when vector objects are converted. 

 Optionally, pre-process the image with the artwork preparation tool. Even if your artwork looks 
ready to stitch, it needs to be image-processed before conversion. However, you will be 
prompted as necessary. See also Process images. 
 

 

 Size the image to the preferred dimensions for your target article. See also Edit artwork. 

 Optionally, select Design Settings > Auto Fabric to apply preferred fabric settings. See also 
Fabrics & densities. 
 

http://www.embroideryhelp.net/display/WILHPD/.Import+images+v1.1
http://www.embroideryhelp.net/display/WILHPD/.Process+images+v1.1
http://www.embroideryhelp.net/display/WILHPD/.Edit+artwork+v1.1
http://www.embroideryhelp.net/display/WILHPD/.Auto+fabrics+v1.1
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 Crop the image as desired using the Crop tools on the Context toolbar. See also Edit artwork. 

 Select the image and click Auto-Digitize Embroidery. If you have not yet processed the image, 
you will be prompted to do so. See also Process images. 

 Image colors are automatically classified as fills or details, or omitted altogether. 

 

 Use the Locate button to isolate selected colors. 

http://www.embroideryhelp.net/display/WILHPD/.Edit+artwork+v1.1
http://www.embroideryhelp.net/display/WILHPD/.Process+images+v1.1
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 Use droplists to tag or omit colors altogether. Fills are always stitched first, outlines, including 
borders or small areas, last. 

 

 Use Up / Down buttons to adjust the stitching sequence. 

 Select a conversion method for color processing. By default, bitmap colors are added to the 
current colorway. Optionally, select a specific thread chart to match to or match colors to the 
current palette. 

 Select a matching method for color processing. 
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 By default, image colors are matched to the nearest thread colors in the current design palette. 
Use 'Add bitmap colors to palette' if you want to add exact image colors to the palette. 
Optionally, choose a thread chart from which to select those colors. 

 Adjust stitching options as preferred. See below. 

 Click OK to process the image. 

 

All editing techniques are available to further refine the auto-digitized image. See also Edit 
objects. 

Stitching options 

The software lets you adjust object recognition settings for any color you identify as a ‘detail’. A 
detail may be a centerline, a border, or a small area of the design you want stitched last. If an 

http://www.embroideryhelp.net/display/WILHPD/Edit+objects
http://www.embroideryhelp.net/display/WILHPD/Edit+objects
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image color is both a fill and a detail, you can either recolor the fill color in a graphics package, or 
omit it for later editing. To adjust detail settings... 

 

 Select a stitching style for details from the droplist: 

Centerline Most suited for use with thin lines. This option will trace the center 
of a color identified as a detail with a run stitch. 

Satin line Suited for use with thicker lines of constant width, usually with 
larger designs. 

Turning satin Most suited for use with thicker lines or small shapes of varying 
width. 

 Click OK to process the image. 

 

 Optionally, add outlines to all color blocks by ticking the Outlines checkbox and selecting a 
color. This has the effect of reinforcing the edges of shapes with a continuous, branched 
running stitch. 
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 Similarly, you can add a border to the entire design by ticking the Border checkbox. 
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DIGITIZE WITH CLICK-TO-STITCH 

The Click-to-Stitch tools provide everything necessary to digitize shapes in bitmap images 
automatically without using manual digitizing methods. These tools are useful for quickly creating 
embroidery objects from scanned images without having to manually digitize shapes. 

It is easy with the Click-to-Stitch tools to double-click and inadvertently create double-layers of 
stitching. Check everything you do in the Resequence Docker and delete any unnecessary objects. 

Digitize fills 

 

Use Auto-Digitize > Click-to-Fill to digitize large artwork shapes with weave fill, preserving any 
holes within. 

 

Use Auto-Digitize > Click-to-Fill without Holes to digitize large artwork shapes with weave fill, 
ignoring any holes within. 

 

Use Auto-Digitize > Click-to-Turning Fill to digitize narrow column artwork shapes with satin 
stitch. 

Click-to-Stitch can be used to create ‘closed’ Tatami Fill objects, as well as objects with turning Satin 
Fills. Use Click-to-Fill to digitize large areas in your artwork with Tattami Fill stitching, preserving 
any holes within them. If you want holes ignored, use the Click-to-Fill without Holes tool. Use Click-
to-Turning Fill to digitize narrow column shapes with turning satin stitching. Current properties are 
applied. You can modify these as required before or after using the tools. To digitize fills with Click-
to-Stitch... 

 Scan and process the artwork. 

 Select a thread color from the Design Palette. 

 Select the appropriate Click-to-Stitch input method. 

 Click the shape you want to digitize. 

 

 Digitize other filled shapes in the artwork in the same way changing thread color and input 
method as required. Click TrueView to check the result. 

 Stitches are generated according to current stitch settings. These can be modified. The 
currently selected color is used. 
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Matched to palette Digitized in current color 

Digitize outlines 

 

Use Auto-Digitize > Click-to-Outline to digitize boundaries of shapes with run stitching using 
current properties. 

 
Use Auto-Digitize > Click-to-Centerline to digitize centerlines in artwork with run line stitches. 

Use Click-to-Stitch to digitize boundaries and details with run stitching. Current properties are 
applied. You can modify the results as you wish. The method is the same as digitizing fills with Click-
to-Fill. Generally you use Click-to-Centerline to trace existing outlines with run stitching. Click-to-
Centerline will always find the center of the outline no matter how thick it is. Depending on its 
thickness, you may obtain double-lines with Click-to-Outline. 

 

Click-to-Outline is generally more useful for detecting boundaries of shapes with no existing 
outlines. 

 

It is a good idea to turn off Match-to-Palette with the outlining tools. Generally you will want to 
select a dark color from the palette to emphasize outlines. 
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AUTO-DIGITIZE PHOTOGRAPHS 

The software provides dedicated techniques for auto-digitizing photographs. Both colored and 
grayscale photos can be used as input. The PhotoFlash effect resembles the output of a line printer. 
Color PhotoStitch produces variegated stitching using multiple thread colors. 

 

You can print design images directly onto a special fabric or transfer via your inkjet printer. 
Printed images can then be combined with Color PhotoStitch to produce stitch highlights on the 
image. For improved results, you may need to edit images using an image editing tool such as 
CorelDRAW, Photo-Paint or Adobe Photoshop. 

 

Auto-digitize with PhotoFlash 

 

Use Auto-Digitize > PhotoFlash to create embroidery designs directly from photographs or 
other images using default settings. 

 

Use View > Show Design to show or hide design elements. Click to open droplist of view 
settings. 

 

Use PhotoFlash to create embroidery from photographs or other images, color or grayscale. Color 
images are automatically converted to grayscale. PhotoFlash designs consist of rows of stitches of 
varying spacing settings. The effect resembles the output of a line printer. For best results, use 
images with well-defined subjects or constantly varying shades. To auto-digitize with PhotoFlash... 

 Scan or load an image. See also Scan images. 

http://www.embroideryhelp.net/display/WILHPD/Scan+artwork
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 Select a thread color. 

 With the image selected, click the PhotoFlash icon. 

 

 The Object Properties > Fill tab gives you control over settings such as grain or orientation, 
stitch angle, density or resolution, as well as background contrast. 
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 Turn off the image - press <D> - for a better view. Experiment with settings for optimum effect 
against your chosen background. 

 

 Select a resolution – Low, Medium, High, or Extra High. The coarser the resolution, the more 
spacing between rows. 

 Select a background option: 

 Light: applies the maximum row width to the lightest part of the image. 

 Dark: applies the maximum row width to the darkest part of the image. 

 The option you select usually depends on whether the fabric is light or dark. The dark option 
produces a negative of the image. 
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 Adjust the grain angle to set the overall angle of stitch lines. 

 

 Adjust the stitch angle to run in a complementary direction to the grain angle. 

 

Auto-digitize with Color PhotoStitch 

 

Use Switch and Convert > Switch to Graphics Mode to import, edit or create artwork as a 
backdrop for embroidery digitizing, manual or automatic. 

 

Use View > Show Design to show or hide design elements. Click to open droplist of view 
settings. 

Use Color PhotoStitch to create embroidery from photographs and other images. While PhotoFlash 
designs consist of rows of single-color satin stitching, Color PhotoStitch produces variegated 
stitching using multiple thread colors. The overall effect is like multi-colored stippling. For best 
results, use crisp images with well-defined subjects and constantly varying shades. 

To prepare the image 

 Scan or insert the image you want to use. For best stitching results, photos are better imported 
via Graphics Mode. 
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 If you cannot see the image, turn on Show Bitmap Artwork. 

 Size the image for its intended purpose. Optimal size is 150mm x 150mm or about 6" x 6". 
210mm is the limit. Alternatively, you will be prompted to resize when you run Color 
PhotoStitch. 

 

 Optionally: 

o Touch up in Graphics Mode. 

o Crop the image. 

o Adjust basic lightness and contrast. For the full range of image adjustment techniques, 
use a dedicated graphics program like PHOTO-PAINT. 

To process the image 

 

Use Auto-Digitize > Color PhotoStitch to automatically turn photographs and other bitmap 
artwork into multi-colored embroidery. 

 With the image selected, click Color PhotoStitch. 
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 Set the number of thread colors. There will be a point a diminishing returns where more colors 
do not always result in greater design clarity or stitchability. Usually 7 to 10 colors produce the 
best results. 

 Use the zoom buttons to examine the previews in detail. You can also zoom in and out with the 
mouse wheel. 

 Optionally, adjust stitching resolution to high, medium, or low. High resolution allows greater 
detail but with a higher stitch count. 
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 Click Adjust Bitmap for further options. Choose between several image variations: 

o Sepia: In photographic terms, ‘sepia’ refers to the dark-brown color of old-fashioned 
prints. Originally the process involved adding a pigment made from cuttlefish ink 
during development. 

o Gray: Grayscale images are ones composed exclusively of shades of gray, varying from 
black at the weakest intensity to white at the strongest. 

 Optionally, adjust basic lightness and contrast if you haven’t already done so. 

 Use Color Matching to assign image colors to the color palette for manual thread matching. 
This ensures the best representation. Alternatively, automatically match them to the current 
color palette or current thread chart. Select one or more available thread charts to match 

 

 Click OK to process the image. 
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To edit the results 

 

Use Edit Objects > Resequence Manually to show or hide Resequence docker. Use it to 
resequence objects and color blocks in a design. 

 Check the results with TrueView on and off. Turn connector stitching on and off. For better 
visualization, set TrueView viewing options to thin thread. 

 

 If you are unsatisfied with the results, click Undo and try again. Try different settings and check 
the previews. You may need to touch up the image in PHOTO-PAINT if none of the results is 
good enough. 

 Edit the results and manually merge thread colors as desired using the Resequence list. 
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 If you have added RGB colors to the color palette, open the Resequence list and My Threads 
dockers side-by-side, and select the thread charts you have available from the Thread Charts 
dialog. 

 Select each color block in turn, check the closest match in My Threads docker, and manually 
choose a thread. Sometimes the closest match may not be the best or be unavailable. Choosing 
the correct thread is key to getting a good result. 
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SMOOTH SHAPES 

 

Use Auto-Digitize / Edit Objects > Smooth Shapes to remove excess reshape-nodes from 
embroidery objects for smoother outlines. 

 

Use Select > Reshape to adjust object outlines, stitch angles, start and end points, curves lines, 
etc. 

Like vector objects, embroidery objects contain reshape nodes on their outlines. On shapes where 
the angle changes constantly, the software may insert hundreds of reshape nodes, making 
reshaping difficult. This is particularly so when using auto-digitizing methods to generate objects. 
The Smooth Shapes command lets you apply curve ‘smoothing’ to embroidery objects. To smooth 
curves... 

 Select the object (or objects) to smooth. You can only smooth objects that have been 
ungrouped and selected. However, you can select multiple objects. 

 Optionally, click the Reshape Object icon. Reshape nodes display around the outline. 

 Click Smooth Shapes and enter the smoothing precision value in millimeters. This value 
controls how closely the smoothed outline follows the original. The larger the precision value, 
the fewer the reshape nodes. 

 

 

 

 

 


