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AUTO-DIGITIZE EMBROIDERY 

The software can automatically convert artwork to embroidery. Artwork is ‘batch processed’ to 
create the many embroidery objects that make up a design. The software can recognize shapes in 
artwork - bitmap and vector - and choose suitable stitch types to use. It can also determine a 
stitching sequence based on closest join. The auto-digitizing tools become available when an image 
is selected. Only one image can be selected at a time. 

Auto-digitizing tools accept artwork in either a raw or processed state. However, the quality of the 
resulting designs greatly depends on the type and quality of the original artwork. Generally 
speaking, vector drawings preserve the picture quality when resized, whereas bitmap images cause 
problems of pixelation and image degradation when enlarged or scaled down. However, any scaling 
required should be done before importing into the software as the importing operation 
automatically transforms vector drawings into bitmaps. In order to make bitmap images more 
suitable for automatic digitizing, the software also provides image processing capabilities and links 
to graphics packages. 

Auto-digitize instant embroidery 

 

Use Auto-Digitize > Auto-Digitize Instant Embroidery to automatically digitize whole embroidery 
design directly from the imported bitmap artwork. 

In essence, creating an embroidery design with the Auto-Digitize Instant Embroidery tool is simply a 
matter of selecting the image you want to convert, and clicking the tool. The system automatically 
determines colors to fill, turn into details, or omit altogether. And it chooses the most suitable 
stitch types to apply using default settings. Even if an image is not pre-processed with the image 
preparation tool, Auto-Digitize Instant Embroidery automatically processes and converts it. Delete 
any unwanted background stitching. Edit stitch colors and types as preferred. 

 

You may want to preset the Design Colors according to your available threads before processing 
the image. Select from a wide range of commercial thread charts. You can assign up to 128 color 
slots. 
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Auto-digitize embroidery (advanced) 

 

Use Auto-Digitize > Auto-Digitize Embroidery to automatically digitize prepared bitmap artwork, 
optionally with user's choices. 

For more control over object conversion, use the Auto-Digitize Embroidery method. This too can 
recognize shapes in artwork, bitmap or vector, and choose suitable stitch types to use. However, it 
provides more control over conversion settings. 

 To use the feature, scan or load an image, and edit and process as necessary.  

 Size the image in the Context toolbar to approximate dimensions. 

 Select the image and click Auto-Digitize Embroidery. If you have not yet processed the image, 
you will be prompted to do so. 

 
 Image colors are automatically classified as fills or details, or omitted altogether. 

 
 Select a color in the list and use the Locate button to preview. The software detects and omits 

the background color by default. 
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 Having located the colors in the design, decide if you want to treat them as fills or details. 

Similarly, decide where you want them to appear in the stitching sequence. Use the droplists to 
reassign colors as preferred. And use the 'Move' buttons to re-sort the color sequence as 
preferred. Fills should always be stitched first, outlines and details, last. 

 
 Select a conversion method for color processing: 
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You have three options: 

o Bitmap colors are added to the current palette (the default). See below. 

o Choose a specific thread chart to match bitmap colors to - click 'Select Thread Charts' 
button to access thread chart listing. 

o Or, match image colors to the nearest colors in the design palette. 

Select stitching options for handling details and outlines:

 
You have three options: 

o Handle details as a centerline, satin line, or a satin fill. Select an option from the 
droplist. 

o Add outlines to all detected color blocks. Tick 'Outlines' and select a thread color from 
the droplist. 

o Add a satin border to the entire design. Again, pick a color from the droplist. 

 Click OK to process the image. 

 
 

 The 'Outlines' option reinforces all color blocks with continuous, branched running stitches. 
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Editing techniques are available to further refine the auto-digitized image. The editing capabilities 
may be limited depending on the level of Hatch you own. 

Assign threads to design palette 

 

Use Customize Design > Threads >> to toggle Threads docker display. Use it to find threads from 
different charts and change design colors. 

 

Use Design Colors > Hide Unused Colors to show or hide all unused colors in the design 
palette. 

 

Use Design Colors > Remove Unused Colors to remove all unused colors from the design 
palette. 

 

Use Threads > Select Thread Charts to select the thread charts you currently have available 
for use. 

 

Use Threads / Customize Design > Match All Design Colors to automatically match and assign 
threads in the thread list to all colors in the Design Color toolbar. 

The software lets you manage thread colors for each design. If you have chosen to add bitmap 
colors to the Design Colors palette (the default), the next step is to assign threads from your 
preferred thread chart to those bitmap colors. Select from a wide range of commercial thread 
charts. Find and sort specific threads by color code. Or let the software automatically match 
threads to bitmap colors. 
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First, note that the bitmap colors have been added to the end of the Design Colors palette and are 
tagged with blue square. (Click the image to enlarge.) 

 

Use the Remove Unused Colors command to collapse the palette to only used colors. Hover the 
cursor over each color. Notice that they are identified only by their RGB values. 

 



   Auto-digitize embroidery 
 
 

 

Hatch 2 Documentation : Auto-digitizing September 26, 2018 7 
 

Choose a thread chart via the docker. For expediency, use the Match All command to match 
threads from the chart to the RGB values. The nearest matching threads are automatically 
assigned. Again, hover the cursor over the design colors to check the assigned threads. 

 

Various techniques are available for changing design colors from the Design Palette. 

Convert artwork to embroidery with CorelDRAW® 

 

Click Switch and Convert > Switch to Graphics Mode to import, edit or create vector artwork as 
a backdrop for embroidery digitizing, manual or automatic. 

 

Click Switch and Convert > Convert Artwork to Embroidery to convert selected vector 
artwork to embroidery objects. 

 

Use Switch and Convert > Convert Artwork to Embroidery to convert selected embroidery 
objects to vector artwork. 

If you have the CorelDRAW® Graphics Suite installed on your system, the software provides 
another option for converting graphics to embroidery designs and vice versa. Individual objects or 
whole designs can be converted. Both vector graphics and bitmaps can be used. Use the Switch and 
Convert toolbar to switch between Embroidery Mode and Graphics Mode in the software. The 
Convert function is also located on the this toolbar. Behavior depends on the operating mode... 

 Graphics can be imported into the system either via Embroidery Mode and Graphics Mode. 

 In Graphics Mode, use the Convert tool to convert selected graphics – vector or bitmaps – 
directly to embroidery. 
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 Selected objects or the entire design are displayed in Embroidery Mode. Here you can edit 

generated embroidery objects, recolor, resize, change stitch types, and so on. 
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 In Embroidery Mode, you have the option of converting embroidery objects to vectors or to 
'virtual embroidery'. 

 
 Virtual embroidery creates a TrueView bitmap image of your design in Graphics Mode. This can 

be saved to file for reference purposes or even printed on fabric. 
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DIGITIZE WITH CLICK-TO-STITCH 

The Click-to-Stitch tools provide everything necessary to digitize shapes in bitmap images 
automatically without using manual digitizing methods. These tools are useful for quickly creating 
embroidery objects from scanned images without having to manually digitize shapes. 

It is easy with the Click-to-Stitch tools to double-click and inadvertently create double-layers of 
stitching. Check everything you do in the Resequence docker and delete any unnecessary objects. 

Digitize fills 

 

Use Auto-Digitize > Click-to-Fill to digitize large artwork shapes with tatami fill, preserving any 
holes within. 

 

Use Auto-Digitize > Click-to-Fill without Holes to digitize large artwork shapes with tatami fill, 
ignoring any holes within. 

 

Use Auto-Digitize > Click-to-Turning Fill to digitize narrow column artwork shapes with satin 
stitch. 

Click-to-Stitch can be used to create ‘closed’ tatami fill objects, as well as objects with turning satin 
fills. Use Click-to-Fill to digitize large areas in your artwork with tatami fill stitching, preserving any 
holes within them. If you want holes ignored, use the Click-to-Fill without Holes tool. Use Click-to-
Turning Fill to digitize narrow column shapes with turning satin stitching. Current properties are 
applied. You can modify these as required before or after using the tools. To digitize fills with Click-
to-Stitch... 

 Scan and process the artwork. 

 Select a thread color from the Design Colors toolbar. 

 Select the appropriate Click-to-Stitch input method. 

 Click the shape you want to digitize. 

 
 Digitize other filled shapes in the artwork in the same way changing thread color and input 

method as required. Click TrueView to check the result. 

 Stitches are generated according to current stitch settings. These can be modified. The 
currently selected color is used. 
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Matched to palette Digitized in current color 

Digitize outlines 

 

Use Auto-Digitize > Click-to-Outline to digitize boundaries of shapes with run stitching using 
current properties. 

 

Use Auto-Digitize > Click-to-Centerline to digitize centerlines in artwork with run line 
stitches. 

Use Click-to-Stitch to digitize boundaries and details with run stitching. Current properties are 
applied. You can modify the results as you wish. The method is the same as digitizing fills with Click-
to-Fill. Generally you use Click-to-Centerline to trace existing outlines with run stitching. Click-to-
Centerline will always find the center of the outline no matter how thick it is. Depending on its 
thickness, you may obtain double-lines with Click-to-Outline. 

 

Click-to-Outline is generally more useful for detecting boundaries of shapes with no existing 
outlines. 

 

It is a good idea to turn off Match-to-Palette with the outlining tools. Generally you will want to 
select a dark color from the palette to emphasize outlines. 
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CONVERT PHOTOS 

The software provides dedicated techniques for auto-digitizing photographs. Both colored and 
grayscale photos can be used as input. The PhotoFlash effect resembles the output of a line printer. 
Color PhotoStitch produces variegated stitching using multiple thread colors. 

 

You can print design images directly onto a special fabric or transfer via your inkjet printer. 
Printed images can then be combined with Color PhotoStitch to produce stitch highlights on the 
image. For improved results, you may need to edit images using an image editing tool such as 
CorelDRAW, Photo-Paint or Adobe Photoshop. 

Auto-digitize with PhotoFlash 

 

Use Auto-Digitize > PhotoFlash to create rows of PhotoSatin stitching of varying spacing in 
current color for selected photographs or other bitmap artwork. The effect resembles the 
output of a line printer. 

 

Use View > Show Design to show or hide design elements. Click to open droplist of view 
settings. 

Use PhotoFlash to create embroidery from photographs or other images, color or grayscale. Color 
images are automatically converted to grayscale. PhotoFlash designs consist of rows of stitches of 
varying spacing settings. The effect resembles the output of a line printer. For best results, use 
images with well-defined subjects or constantly varying shades. To auto-digitize with PhotoFlash... 

 Scan or load an image. 



   Convert photos 
 
 

 

Hatch 2 Documentation : Auto-digitizing September 26, 2018 13 
 

 
 Select a thread color. 

 With the image selected, click the PhotoFlash icon. 

 
 The Object Properties > Fill tab gives you control over settings such as grain or orientation, 

stitch angle, density or resolution, as well as background contrast. 
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 Turn off the image - press <D> - for a better view. Experiment with settings for optimum effect 

against your chosen background. 

 
 Select a resolution – Low, Medium, High, or Extra High. The coarser the resolution, the more 

spacing between rows. 

 Select a background option: 

o Light: applies the maximum row width to the lightest part of the image. 

o Dark: applies the maximum row width to the darkest part of the image. 

The option you select usually depends on whether the fabric is light or dark. The dark option 
produces a negative of the image. 

 Adjust the grain angle to set the overall angle of stitch lines. 



   Convert photos 
 
 

 

Hatch 2 Documentation : Auto-digitizing September 26, 2018 15 
 

 
 Adjust the stitch angle to run in a complementary direction to the grain angle. 

 

Auto-digitize with Color PhotoStitch 

 

Click Switch and Convert > Switch to Graphics Mode to import, edit or create vector artwork as 
a backdrop for embroidery digitizing, manual or automatic. 

 

Use View > Show Design to show or hide design elements. Click to open droplist of view 
settings. 

Use Color PhotoStitch to create embroidery from photographs and other images. While PhotoFlash 
designs consist of rows of single-color satin stitching, Color PhotoStitch produces variegated 
stitching using multiple thread colors. The overall effect is like multi-colored stippling. For best 
results, use crisp images with well-defined subjects and constantly varying shades. 

The software has width and height limits for Color PhotoStitch processing. If the image height or 
width is greater than 210 mm, the larger dimension will be reduced to around 150 mm. A 200 
mm x 200 mm image will not be reduced in size but a 220 mm x 220 mm image will be reduced to 
approximately 150mm x 150mm. Best results are generally obtained with images smaller than 
150 mm. 
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To prepare the image 

 Scan or insert the image you want to use. For best stitching results, photos are better imported 
via Graphics Mode. 

 
 If you cannot see the image, turn on Show Bitmap Artwork. 

 Size the image for its intended purpose. Optimal size is 150mm x 150mm or about 6" x 6". 
210mm is the limit. Alternatively, you will be prompted to resize when you run Color 
PhotoStitch. 

 
 Optionally: 

o Touch up in Graphics Mode. 

o Crop the image. 

o Adjust basic lightness and contrast. For the full range of image adjustment techniques, 
use a dedicated graphics program like PHOTO-PAINT. 
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To process the image 

 

Use Auto-Digitize > Color PhotoStitch to automatically turn grayscale or color photographs into 
embroidery. 

 With the image selected, click Color PhotoStitch. 

 
 Set the number of thread colors. There will be a point a diminishing returns where more colors 

do not always result in greater design clarity or stitchability. Usually 7 to 10 colors produce the 
best results. 

 Use the zoom buttons to examine the previews in detail. You can also zoom in and out with the 
mouse wheel. 

 Optionally, adjust stitching resolution to high, medium, or low. High resolution allows greater 
detail but with a higher stitch count. 
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 Click Adjust Bitmap for further options. Choose between several image variations: 

o Sepia: In photographic terms, ‘sepia’ refers to the dark-brown color of old-fashioned 
prints. Originally the process involved adding a pigment made from cuttlefish ink 
during development. 

o Gray: Grayscale images are ones composed exclusively of shades of gray, varying from 
black at the weakest intensity to white at the strongest. 

 Optionally, adjust basic lightness and contrast if you haven’t already done so. 

 Use Color Matching to assign image colors to the color palette for manual thread matching. 
This ensures the best representation. Alternatively, automatically match them to the current 
color palette or current thread chart. Select one or more available thread charts to match to. 

 
 Click OK to process the image. 
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To edit the results 

 

Use Edit Objects > Sequence >> to open the Sequence docker. Click again to close. Also available 
via Windows > Dockers menu. 

 Check the results with TrueView on and off. Turn connector stitching on and off. For better 
visualization, set TrueView viewing options to thin thread. 

 
 If you are unsatisfied with the results, click Undo and try again. Try different settings and check 

the previews. You may need to touch up the image in PHOTO-PAINT if none of the results is 
good enough. 

 Edit the results and manually merge thread colors as desired using the Sequence docker. 

 
 If you have added RGB colors to the color palette, open the Sequence docker and Threads 

dockers side-by-side, and select the thread charts you have available from the Thread Charts 
dialog. 

 Select each color block in turn, check the closest match in Threads docker, and manually 
choose a thread. Sometimes the closest match may not be the best or be unavailable. Choosing 
the correct thread is key to getting a good result. 
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SMOOTH SHAPES 

Like vector objects, embroidery objects contain reshape nodes on their outlines. On shapes where 
the angle changes constantly, the software may insert hundreds of reshape nodes, making 
reshaping difficult. This is particularly so when using auto-digitizing methods to generate objects. 
The Smooth Shapes command lets you apply curve ‘smoothing’ to embroidery objects. 

To smooth curves... 

 

Use Auto-Digitize / Edit Objects > Smooth Shapes to remove excess reshape-nodes from 
selected embroidery objects. 

 

Use Select > Reshape to reshape an object shape, edit stitch angles, adjust entry and exit 
points, or customize envelopes. 

 Select the object (or objects) to smooth. You can only smooth objects that have been 
ungrouped and selected. However, you can select multiple objects. 

 Optionally, click the Reshape Object icon. Reshape nodes display around the outline. 

 Click Smooth Shapes and enter the smoothing precision value in millimeters. This value 
controls how closely the smoothed outline follows the original. The larger the precision value, 
the fewer the reshape nodes. 
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COPYRIGHT 

Copyright © 2018. Wilcom Pty Ltd, Wilcom International Pty Ltd. All Rights reserved. 

No parts of this publication or the accompanying software may be copied or distributed, transmitted, transcribed, 
stored in a retrieval system or translated into any human or computer language, in any form or by any means, 
electronic, mechanical, magnetic, manual, or otherwise, or disclosed to any third party without the express written 
permission of: 

Wilcom Pty Ltd. (A.B.N. 43 001 971 919) 
Level 3, 1-9 Glebe Point Rd, Glebe 
Sydney, New South Wales, 2037, Australia 
PO Box 1094, Broadway, NSW 2007 
Phone: +61 2 9578 5100 
Fax: +61 2 9578 5108 
Email: wilcom@wilcom.com 
Web: http://www.wilcom.com 

TrueView™ and Point & Stitch™ are trademarks of Wilcom Pty Ltd. Portions of the imaging technology of this 
Product are copyrighted by AccuSoft Corporation. The EPS File Import/Export Converter used in this Product is 
copyrighted by Access Softek, Inc. All rights reserved. 

Wilcom Pty Ltd makes no representation or warranties with respect to the contents of this publication and 
specifically disclaims any implied warranties of merchantable quality or fitness for any particular purpose. Further, 
Wilcom Pty Ltd reserves the right to revise this publication and to make changes in it from time to time without 
obligation of Wilcom Pty Ltd to notify any person or organization of such revisions or changes. 

The screen illustrations in this publication are intended as representations, not exact duplicates of screen layouts 
generated by the software. The samples used to illustrate software features and capabilities may not be exactly 
duplicable, depending on inclusions provided with your software model or product level. Some artwork for design 
samples is kindly provided by Digital Art Solutions. 

Subject to any warranties implied by law which are incapable of limitation or exclusion, the software is purchased 
‘as is’ without any warranty as to its performance, accuracy, freedom from error or to any results generated 
through its use and without any implied warranty of merchantability or of fitness for any particular purpose for 
which the software is being acquired. The purchaser relies on its own skill and judgement in selecting the software 
for its own use and assumes the entire risk as to the results and performance of the software. Wilcom Pty Ltd 
specifically does not warrant that the software will meet the purchaser’s requirements or operate without 
interruption or error. 
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