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EDIT OBJECTS 

In addition to making global changes to a design, such as changing the thread palette and design 
colors, some product levels allow you to edit design objects and even individual stitches. When 
available, the Edit Objects toolbox provides many tools for reshaping, resizing, rotating objects, as 
well as add or remove stitch angles. Other editing functions are available via the Context toolbar, 
popup menu, and Edit menu. Explore the topics on the right to find out what else you can do with 
the software’s editing features. 

 

The Edit Objects toolbox also provides specialized features to create special effects as well as save 
time while you digitize. From sunsets to wood grains, color blending creates interesting color 
blends, perspective effects and shading effects. The Ambience Quilting feature is used to create 
‘echo’ quilting designs. Quickly create outline stitching around selected objects or entire designs 
with Single, Triple or Satin Line. 

Designs, fonts and other elements used in this video may not be available in your software, 
depending upon purchased options. 

Selection functions 

Keyboard shortcuts are available for most selection functions. Not all shortcuts are applicable to all 
product levels. 

To Press 

Choose Select tool <O> 

Select multiple objects <Ctrl> + left-click 

Select a range of objects <Shift> + left-click first and last objects 

Select next object <Tab> 

Select previous object <Shift + Tab> 

Add next object to selection <Ctrl + Tab> 

Add previous object to selection <Ctrl + Shift + Tab> 

http://www.embroideryhelp.net/display/HATCH/.Ambience+quilting+v2.0
http://www.embroideryhelp.net/display/HATCH/.Outlines+offsets+v2.0
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To Press 

Select all objects <Ctrl + A> 

Deselect all objects <Esc> or <X> 

Editing functions 

Keyboard shortcuts are available for most editing functions. Not all shortcuts are applicable to all 
product levels. 

To Press 

Center current stitch <C> 

Cut selected objects <Ctrl + X> 

Copy selected objects <Ctrl + C> 

Paste selected objects <Ctrl + V> 

Duplicate selected objects <Ctrl + D> 

Duplicate selected objects with offset <Ctrl + Shift + D> 

Delete selected objects <Delete> 

Group selected objects <Ctrl + G> 

Ungroup selected objects <Ctrl + U> 

Lock selected objects <K> 

Unlock objects <Shift + K> 

Reshape selected objects <H> 

Apply closest join to selected objects <J> 

Nudge selected objects Left-click + arrow keys 

Undo a command <Ctrl + Z> 

Redo a command <Ctrl + Y> 

Cancel a command <Esc> 

Delete last reference point (when digitizing) <Bksp> 

Toggle underlay in selected objects on/off <U> 

The screen illustrations in this publication are intended as representations, not exact duplicates of 
screen layouts generated by the software. The samples used to illustrate software features and 
capabilities may not be exactly duplicable, depending on inclusions provided with your product 
level. 
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OBJECT PROPERTIES 

Designs are composed of ‘embroidery objects’. They are called ‘objects’ because they can be 
manipulated independently of each other. Like drawing objects, embroidery objects have defining 
characteristics or ‘properties’ such as color, size, position, and so on. They also have properties 
unique to embroidery such as stitch type and density. The most important property of an 
embroidery object is its stitch type. Other important properties include underlay type and pull 
compensation. 

 

Access properties 

 

Use Edit Objects > Object Properties to show Object Properties docker. Use to preset properties 
for new embroidery objects or adjust properties for selected embroidery objects. 

When you start a new design, the software uses settings associated with the chosen fabric. Some 
properties can be modified on-screen – for example, you can change object size by scaling with 
selection handles. Others, such as stitch spacing or length, can be modified via the Object 
Properties docker. This docker is open by default. 

 To change object properties, select the object/s to change. 

 If not already open, double-click to open the properties docker. If you select more than one 
object, only settings relevant to all are displayed. 
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 Select a tab and adjust settings. 

 Click OK to apply changes. 

Changing details of selected objects does not affect default settings, nor the properties of any 
objects not in the selection. Changes to object properties are preserved if an object is modified 
and regenerated. 

Copy properties 

 

Use Edit Objects > Copy Object Properties to make properties of a selected object current for 
the design. 

 
Use Edit Objects > Apply Object Properties to apply current settings to selected objects. 

You can make a selected object’s ‘actual’ properties ‘current’ for all new objects or apply them to 
other objects. 

 To copy properties, select the object and click Copy Object Properties. 

 Alternatively, right-click the object and use the popup menu command. 
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 Select the target object/s and click Apply Object Properties. The popup menu command is also 

available. 

 

Adjust stitch spacing 

 

Use Customize Design / Edit Objects > Adjust Stitch Spacing to manually override stitch densities 
for selected objects. 

The software lets you change spacing of most stitch types across the whole or selected parts of a 
design. To override current properties, select the object, click the tool, and set a percentage 
adjustment - e.g. 150% to increase stitch spacing and thereby reduce overall density. Check the 
revised stitch count in the Status Bar. See also Fabrics & densities. 

 

http://www.embroideryhelp.net/display/HATCH/.Fabrics+and+densities+v2.0
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Corner stitching 

 

Use Context > Automatic Corners to turn automatic corners on or off. When turned on, the 
corners in line objects will be mitred or capped automatically depending on how sharp the 
corner turns. Can be turned on or off on an object by object basis. 

The quality and style of corners is important in borders and appliqué, and satin column sewing in 
general. Sharp corners may cause stitch bunching which can create hard spots in the embroidery 
and may damage fabric or needle. The Automatic Corners feature helps you control sharp corners 
in satin objects. When the function is applied, corner types are automatically optimized according 
to corner angle. 
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ARRANGE OBJECTS 

Position objects in your design using the mouse to 
drag them to a new position, nudging them with 
the arrow keys or by specifying the X:Y 
coordinates in the Customize toolbar. 

 

 

 

 

 

 

 

Position objects 

 

Use Select > Select Object to select an object or group. Or drag a selection marquee to select 
multiple enclosed objects or groups. 

 

The simplest way to move an object in your design is to click and drag it to a new position. For 
more accurate positioning, press the arrow keys to ‘nudge’ the object into the required position. 

 

You can also position selected objects relative to the center of a design by entering its X:Y 
coordinates in the Customize toolbar which appears whenever you select objects. Use the ruler 
(Ctrl + R) for more precise measurements. 
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Align objects 

 
Use Context > Align Centers to align the centers of selected objects. 

 

Quickly align selected objects in a design to the left, right, top, bottom or center of a specific object. 
The Align commands can be accessed via the Arrange menu or the popup menu. The commands 
are all enabled when two or more objects are selected. Objects are aligned with the last object 
selected. 

 

Space objects 

 
Use Context > Space Evenly Across to evenly space 3 or more selected objects horizontally. 

 
Use Context > Space Evenly Down to evenly space 3 or more selected objects vertically. 

 

Use the same method to space selected objects evenly across or down screen. 
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TRANSFORM OBJECTS 

Often you will want to scale a design for use in different contexts. For instance, a design originally 
made to fit a pocket may be adapted to fit a cap. The software provides techniques for 
transforming design objects just like a graphics program ... with one difference. When you scale, 
rotate, skew, or flip an embroidery object, stitches are regenerated. 

The scalability and stitching quality of a design ultimately depend on its original source. Only 
native designs such as EMB or JAN, contain the complete set of design information required for 
100% perfect scaling and transformation. If you scale a stitch design by more than 10%, changes 
to stitch density will affect design quality. 

Scale objects 

 

Use Select > Select Object to select an object or group. Or drag a selection marquee to select 
multiple enclosed objects or groups. 

 
Use Context > Size + 10% to increase the size of selected objects in 10% increments. 

 
Use Context > Size - 10% to decrease the size of selected objects in 10% increments. 

 

You can scale objects by dragging the selection handles with the mouse or by specifying the exact 
dimensions in the Context toolbar. As an object is scaled, the stitch count changes to preserve 
current stitch spacing. 

 To scale objects using click and drag, select the object/s to scale. Click and drag a selection 
handle to resize the object. 

 
 You can also scale selected objects or a whole design using Width and Height settings. Stitches 

are regenerated and original stitch density preserved. 
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 Alternatively, use the Size buttons to resize in 10% increments. 

After scaling, the new object size is reset to 100%. 

Rotate objects 

 

Use Select > Select Object to select an object or group. Or drag a selection marquee to select 
multiple enclosed objects or groups. 

 
Use Context > Rotate Left 15° to rotate selection in 15° increments to the left. 

 
Use Context > Rotate Right 15° to rotate selection in 15° increments to the right. 

 

When creating design layouts, you’ll frequently find yourself duplicating objects and rotating them 
into position. 

 When you select an object or group, selection handles display at its extremities. Click the 
object a second time. Rotation handles appear at the corners of the object and an anchor point 
displays at the object’s center. Click a rotation handle, and drag clockwise or anti-clockwise. 
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 If required, drag the rotation anchor from the center to a new position. 

 Alternatively, use the buttons to rotate selections by 15° rotations in either direction. 
Alternatively enter a precise rotation value in the Rotate field and press <Enter>. 

 
 Alternatively, right-click the object and select a Rotate command from the popup menu. 

Skew objects 

 

Use Select > Select Object to select an object or group. Or drag a selection marquee to select 
multiple enclosed objects or groups. 

 

You can skew objects along the horizontal plane by clicking skew handles and dragging to the 
required angle. Skew handles are diamond-shaped and appear at the center-top and bottom of the 
object. Alternatively enter a precise skew value in the Skew field and press <Enter>. 
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Mirror objects 

 
Use Context > Mirror X to flip selection horizontally. 

 
Use Context > Mirror Y to flip selection vertically. 

 

Fashion and textile designs often use copied and mirrored 
design elements. You can mirror objects horizontally or 
vertically by means of the Mirror tools on the Context toolbar. 
Select objects to mirror and click a Mirror icon. For productivity, 
shortcut keys are available for mirror operations. 

 

The Mirror-Copy tools allow you to duplicate and transform selected embroidery objects, as well 
as merge them into a single object. This feature is often used in making fashion or textile designs. 
See also Mirror-copy objects. 

http://www.embroideryhelp.net/display/HATCH/.Mirror+objects+v2.0
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RESHAPE OBJECTS 

You modify object shapes in your embroidery 
software by means of control points similar to 
objects in a graphics package. These vary 
slightly with object type. For some objects, you 
can change control points from corners to 
curves. Stitch angle adjustments depend on 
object type. With some objects you can set a 
single stitch angle. With others, you adjust 
turning angles. You can also change entry and 
exit points. This is useful in order to minimize 
travel runs between objects. Modify outline by 
adding, deleting, or moving control points. 

Adjust control points 

 

Use Select > Select Object to select an object or group. Or drag a selection marquee to select 
multiple enclosed objects or groups. 

 

Use Select > Reshape to reshape an object shape, edit stitch angles, adjust entry and exit 
points, or customize envelopes. 

 

Control points can be selected individually or together, for repositioning or modification. 

 Click to select a single control point. 

 
 Holding down <Ctrl>, click to select multiple control points. Or click and drag a bounding box 

around a group of control points. 
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 Press <Delete> to delete selected control points. 

 Add control points to object outlines by clicking with the Reshape tool selected. Left-click to 
add a corner point. Right-click for curve points. 

 
 Reposition control points to change an outline shape. Simply click and drag to a new position 

along the boundary. Or click and drag multiple points as needed. Use the arrow keys to ‘nudge’ 
selected reshape nodes. 

 
 Press <Spacebar> to toggle between corner and curve points. 
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 If you make a mistake, press <Ctrl> + <Z> to undo changes. Press <Esc> to exit Reshape mode. 

 When in Reshape mode, use the <Tab> or <Shift + Tab> keys to jump between objects. 

 

Smooth shapes 

 

Use Auto-Digitize / Edit Objects > Smooth Shapes to remove excess reshape-nodes from selected 
embroidery objects. 

 

Like vector objects, embroidery objects contain reshape nodes on their outlines. On curved shapes, 
the software may insert hundreds of nodes, making reshaping difficult. This is particularly so when 
using auto-digitizing methods to generate objects. And even more so if the edges of shapes are 
jagged. The Smooth Shapes command lets you apply curve ‘smoothing’ to embroidery objects. See 
also Smooth shapes. 

 

http://www.embroideryhelp.net/display/HATCH/Smooth+shapes
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Adjust entry & exit points 

 

Use Select > Reshape to reshape an object shape, edit stitch angles, adjust entry and exit points, 
or customize envelopes. 

 

You can change stitch entry and exit points of individual objects. Do this to place the exit point next 
to adjoining objects for smaller connecting stitches, or to reduce the number of travel runs. Select 
the entry or exit point as required, and drag it to a different position on the object outline. The 
cross represents the end point. 

 Select the object and click Reshape Object. Reshape nodes appear, including entry and exit 
points. 

 
 Select the entry or exit point as required, and drag it to a different position on the object 

outline. To minimize gaps in your embroidery, place entry and exit points opposite each other 
on the outside boundary. 

 
 Press <Enter> to apply the changes, then <Esc> to finish. 

 It’s a good idea to define the stitch angle so it is perpendicular to the line between entry and 
exit points. 

The default Closest Join method automatically calculates the closest join between objects while 
digitizing – no need to think about object entry and exit points. The Software Settings > User 
Interface > General tab lets you deactivate if so required. When deactivated, all newly digitized 
objects are joined by the As Digitized method. This means you are prompted to enter entry and 
exit points as you digitize. 
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Reshape circle objects 

 

Use Select > Reshape to reshape an object shape, edit stitch angles, adjust entry and exit points, 
or customize envelopes. 

You can change Circle objects to ovals using the 
Reshape tool. Circle objects have two reshape 
control points (used to change the radius and 
orientation of the object), a center point (used to 
reposition it), and a stitch entry point. You cannot 
add, change or delete control points in these 
objects. 

 

 

 

Adjust stitch angles 

 

Use Edit Objects / Digitize > Add Stitch Angles to add stitch angles to selected closed objects 
with or without holes. 

 

Use Edit Objects > Remove Stitch Angles to remove stitch angles from selected objects with 
turning stitching. 

 

Stitch angle adjustments depend on the type of object you are working with. With filled objects you 
can set a stitch angle for the entire object. Alternatively, you can add multiple stitch angles with the 
Add Stitch Angles tool. You can also adjust the stitch angle using the Reshape Object tool. See also 
Stitch angles. 

 

In Circle objects, only the entry point appears. The stitch angle is perpendicular to the line 
connecting the entry point to the circle center. Thus, changing the stitch entry point in a Circle 
object changes its stitch angle. 

http://www.embroideryhelp.net/display/HATCH/Stitch+angles
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Remove underlying stitching 

 

Use Edit Objects > Remove Overlaps to remove stitches that are covered by the selected objects. 
Overlap value can be changed in the Overlap tab of Embroidery Settings dialog. 

 

Use the Remove Overlaps tool to remove underlying 
layers of stitching in overlapping objects. This helps to 
reduce the stitch count and prevent a build-up of 
stitches where they are not needed. See Manipulate 
objects for details. 

http://www.embroideryhelp.net/display/HATCH/.Manipulate+objects+v2.0
http://www.embroideryhelp.net/display/HATCH/.Manipulate+objects+v2.0
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COLOR BLENDING 

From sunsets to wood grains, color blending creates interesting color blends, perspective effects 
and shading effects. Two colors are merged smoothly from one to another using a mixture of dense 
and open fill. 

 

Apply color blending 

 

Use Edit Objects > Create Color Blend to generate color blends, perspective effects and shading 
in selected objects. 

 

Color blending can be applied to most objects filled with satin, 3D satin, tatami, or zigzag stitching. 

 Select an object. 

 To prevent underlay stitching from showing through, deselect underlay. Travel on Edge is 
applied by default. See also Gradient fill. 

 Click Create Color Blend. The Color Blending dialog opens. 
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 Select a profile for top or bottom layers. Normally, the corresponding layer is automatically 
selected so that rows blend into one another. However, the bottom layer contains an 
additional ‘even profile’ option. This can be used with any of the top layer profiles. 

 Choose complementary colors for each layer and adjust spacing settings. Generally, you will 
want to use the same spacing values so that rows blend evenly. 

 

Edit color blends 

 

Use Context > Group to group selection. Or press <Ctrl+G>. This tool is also available via 
Arrange menu. 

 

Use Context > Ungroup to ungroup grouped selection. Or press <Ctrl+U>. This tool is also 
available via Arrange menu. 

 

Use Select > Reshape to reshape an object shape, edit stitch angles, adjust entry and exit 
points, or customize envelopes. 

 

Objects with color blending can be resized, rotated and skewed without losing the color blending 
effect. The two components must first be ungrouped and objects edited separately. 

 Select the blended object and press <Ctrl+U> to ungroup. 

 
 Select an object and change color as required. 
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 Double-click the object to open the Object Properties dialog. 

 In the Effects tab, select a profile and adjust spacing settings as required. Repeat the process 
for the second object. 

 
 Optionally, use Reshape to adjust gradient orientation. 

 
 When you have finished editing, re-group the blended objects. 
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CLOSEST JOINS 

Designs stitch out more efficiently when the 
connectors between objects are short. This also 
tends to reduce the number of trims in a design. 
The software has a Closest Join method which can 
be applied while digitizing and/or after editing. 
When activated, entry and exit points of objects are 
automatically placed close together while you 
digitize. However, closest joins are not 
automatically maintained when objects are moved, 
re-sequenced, or edited. Closest Join can be (re-
)applied to selected objects or entire designs after 
editing. 

Connectors link objects in a design. They can be run stitches or jumps. You can use automatic 
settings to generate connectors, trims and tie-offs, or add them manually. If you prefer to add tie-
offs and trims as you digitize, you can turn off automatic connectors altogether. See also 
Embroidery connections. 

Apply closest join 

 

Use Edit Objects > Apply Closest Join to join selected objects at the closest point. Re-apply 
closest join after editing. 

 

When you are digitizing closed objects, the Closest Join method automatically calculates the closest 
join between them, saving you having to think about entry and exit points. The Apply Closest Join 
feature allows you to (re-)apply closest join to selected objects after editing. The image below 
shows a) joins as digitized, b) joins after repositioning, c) joins after reapplying closest join. The 
Apply Closest Join command is only enabled when two or more embroidery objects are selected. 

 

The Apply Closest Join is also available from the Edit menu or by pressing <J>. 
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The software also allows you to manually change entry and exit points of individual objects. See 
also Reshape objects. 

Closest join option 

The Closest Join method (the default) automatically calculates closest join between objects while 
digitizing. When deactivated, entry/exit points of all newly digitized objects are set manually. If you 
want to deactivate it for this purpose, choose Embroidery Settings from the Software Settings 
menu and deactivate the option on the Design tab. 

 

When deactivated, all newly digitized objects are joined by the ‘As Digitized’ method. As shown in 
the first example below. 

 

This means that you manually specify entry and exit points while digitizing. Generally it’s good to 
check entry and exit points before stitching out. See also Reshape objects. 

Closest join limitations 

The Apply Closest Join feature is not applicable to all objects in all circumstances. Closest Join 
requires the complete stitch regeneration of the selected objects – the whole object, not just 
connectors. Stitch regeneration has its limitations: 

 Recognized objects – i.e. opened from stitch files – may generate poor or incorrect embroidery. 

 Manual (unrecognized) objects cannot be changed by stitch regeneration. Thus Closest Join will 
not work properly for them. 



   Closest joins 
 
 

 

Hatch 2 Documentation : Edit objects September 28, 2018 24 
 

 Manual stitch edits to objects will be lost. 

 Manually inserted machine functions may be mistakenly regenerated on the underlay. 

 Nested objects are not supported. They will become un-nested and placed after the object in 
which they were originally nested. 

The Closest Join technique is not as powerful as Branching for run objects. The best it can do is 
swap the ends of the runs whereas Branching produces a nicely-merged double-run joined in the 
middle. See also Embroidery connections. 
 

 

Obviously, it only makes sense to apply closest join to sequential objects. Any non-sequential 
embroidery objects in the selection will trigger an error message. 
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EMBROIDERY CONNECTIONS 

Connectors link objects in a design. They can be run stitches or 
jumps. You can use automatic settings to generate connectors, 
trims and tie-offs, or add them manually. If you prefer to add 
tie-offs and trims as you digitize, you can turn off automatic 
connectors altogether. 

The software also allows you to create ‘branched objects’. Selected objects are resequenced, 
connectors minimized, components grouped, and stitches regenerated. Underlay can be applied 
to all. See also Branching & redwork. 

View connectors 

 

Use View > Show Design to show or hide design elements. Click to open droplist of view 
settings. 

 

Use Select > Reshape to reshape an object shape, edit stitch angles, adjust entry and exit 
points, or customize envelopes. 

Turn on connectors via the Show Design droplist or press <Shift + C>. The triangle indicates a trim, 
while a dotted line indicates a jump. In TrueView, jumps do not appear. 

 

http://www.embroideryhelp.net/display/HATCH/.Branching+Redwork+v2.0
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When studying connectors, you may find that the distance between consecutive objects is not as 
close as it could be. To adjust connecting stitches, use Reshape to reset entry and exit points. 

 

The Apply Closest Join feature allows you to (re-)apply closest join to selected objects after 
editing. The command is enabled when two or more embroidery objects are selected. See Closest 
joins. 

Automatic connectors 

 

Use Context > Always Tie-Off & Trim to trim connectors. When turned on, connectors will 
always be tied off and trimmed. Otherwise, the software will decide when to trim. 

 

Use Edit Objects > Object Properties to show Object Properties docker. Use to preset 
properties for new embroidery objects or adjust properties for selected embroidery objects. 

 

The software generates connecting stitches both within and between objects, based on Object 
Properties. You can use the Always Tie-Off & Trim tool on the Context toolbar to force the use of 
trims when you don’t want connecting stitches to appear. For instance, lettering objects often 
contain connecting stitches between letters. In the sample below, the first object uses default 
settings and includes connecting stitches between letters ‘b_l_i_c_k’. The second object includes 
trims between each letter as indicated by the small triangles. The Always Tie-Off & Trim tool will 
appear on the Context toolbar whenever you choose one or more embroidery objects. See also 
View embroidery elements. 

 

http://www.embroideryhelp.net/display/HATCH/.View+embroidery+elements+v2.0
http://www.embroideryhelp.net/display/HATCH/.View+embroidery+elements+v2.0
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You can change connector settings for a whole design or selected objects. Sometimes, for instance, 
you may want to insert a jump as a connector between embroidery objects. The software inserts 
Tie-off and Trim functions which command the machine to cut the connecting thread. The easiest 
way to do so is to select the first object and click Always Tie-Off & Trim on the Context toolbar. 

 

At other times, you may actually want the software to turn off Trims and Tie-offs for selected 
objects or for entire designs. For instance, if the connecting run is hidden beneath another object, it 
is more efficient to use a connecting run rather than a trim and tie-off. You can do this via the 
Object Properties > Stitching tab. The following settings apply selectively to tie-ins, tie-offs, and/or 
trims. They work both for selected objects and when digitizing new objects. 

Setting Purpose 

On, if next 
connector >= 

When selected, automatic trims are applied when connectors are greater than or equal 
to the specified value (default = 3mm). This setting can be activated for selected objects. 
The ‘Always Tie-off and Trim’ icon on the Context toolbar is enabled but not activated. 

Always When selected, automatic trims will always be applied when digitizing or to selected 
objects. This setting is activated whenever the ‘Always Tie-off and Trim’ icon is activated. 

Off This has the effect of turning off trims when digitizing. The setting can be turned off for 
selected objects. When selected, the ‘Always Tie-off and Trim’ icon on the Context 
toolbar is greyed out. 
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SEQUENCE DESIGNS 

The embroidery objects in a design form a 
stitching sequence. Initially, objects are stitched 
in the order in which they were created. 

As a general rule, it is important to establish the 
stitching order so that objects in the foreground 
are sewn after those in the background. If you 
combine designs or design elements, you will 
also want to ensure that like-colors are sewn 
together. 

You can change the position of selected objects 
by cutting and pasting elsewhere in the 
sequence. The Sequence docker provides 
various techniques for sequencing objects or 
entire color blocks in a design. 

The Sequence docker provides an easy way to view color blocks and individual objects in a design. 
Use the ‘Switch’ buttons on the Sequence docker toolbar to toggle between color blocks and 
individual objects. The Design Colors toolbar offers an easy way to selectively view color blocks 
and embroidery objects. This is useful when re-sequencing. See also Design colors and Viewing 
methods. 

Sequence by cut & paste 

 

Click Standard > Copy to copy the selection and place it on the clipboard. This tool is also 
available via Edit menu. 

 

Click Standard > Cut to cut the selection and place it on the clipboard. This tool is also available 
via Edit menu. 

 

Click Standard > Paste to paste contents of the clipboard. This tool is also available via Edit 
menu. 

You can sequence objects by cutting an object from the design and pasting it back at a different 
point in the sequence. This does not change the physical location of the object. 

 

Cut the object to sequence and paste. By default, the object is pasted at the end of the sequence. 
Alternatively, travel to a point in the stitching sequence where you want to paste the object. You 
can paste between other objects or ‘nest’ the cut object within another object. 

http://www.embroideryhelp.net/display/HATCH/.Design+colors+v2.0
http://www.embroideryhelp.net/display/HATCH/.View+methods+v2.0
http://www.embroideryhelp.net/display/HATCH/.View+methods+v2.0
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Sequence by objects 

 

Use Edit Objects > Sequence >> to open the Sequence docker. Click again to close. Also 
available via Windows > Dockers menu. 

 
Use Sequence > Show Object List to display individual object thumbnails in the docker. 

 
Use Sequence > Show More to show more details in the docker. Object thumbnails are not 
resizable. 

 
Use Sequence > Show Less to show only summary details in the docker. Object thumbnails 
are not resizable. 

 

The Sequence docker provides an easy way to select design objects and reposition them in the 
preferred sequence. 

 Switch to Object List view via the toggle. 

 
 Use the ‘More’ button to display more information about each design object, including object 

type, stitch type used, and number of stitches. 

 
 Click to select the object or objects you want to sequence. Hold down <Ctrl> to select 

multiples. 
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Use Sequence > Move Up to move the selection up one object or color block, depending on 
display mode. 

 
Use Sequence > Move Down to move the selection down one object or color block, depending 
on display mode. 

 
Use Sequence > Move to Top to move the selection to the top of the stitching sequence. 

 
Use Sequence > Move to End to move the selection to the end of the stitching sequence. 

 Use the buttons on the toolbar to reposition the selection in the list. Alternatively, drag-and-
drop to the required position. The list will scroll automatically. 

 

The Apply Closest Join feature allows you to (re-)apply closest join to selected objects after 
editing. It is available from the Edit menu or by pressing <J>. See also Closest joins. 

Sequence by color 

 

Use Sequence > Show Color List to display color blocks with included object thumbnails in the 
docker. 

 
Use Sequence > Move Up to move the selection up one object or color block, depending on 
display mode. 

 
Use Sequence > Move Down to move the selection down one object or color block, 
depending on display mode. 

 
Use Sequence > Move to Top to move the selection to the top of the stitching sequence. 

 
Use Sequence > Move to End to move the selection to the end of the stitching sequence. 

The Sequence docker also provides an easy way to sequence designs by color. Switch to Color List 
view via the toggle. Select the color block or blocks you want to sequence. Hold down <Ctrl> to 
select multiples. 
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Use the buttons on the toolbar or drag-and-drop to reposition the selection. 
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Sequence by selection order 

 

Use Edit Objects / Sequence docker > Sequence by Selection Order to resequence objects in the 
order of selection. Hold down <Ctrl> and click to select. 

Another useful technique is to sequence objects by order of selection. This works in either object 
view or color view. Simply select the first object or color block you want to include in the sequence. 
Holding down <Ctrl>, select subsequent objects in the desired stitching order. You can do this on-
screen or with the Sequence docker. 

 

Click the Sequence by Selected Order button. The objects are sequenced in the order of selection. 
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Sequence by color 

 

Use Sequence > Sequence by Color to resequence selected color blocks in the Sequence docker. 
Hold down <Ctrl> and click to select. 

Yet another sequencing technique is to sequence selected color blocks. Simply the color blocks you 
want to include in the sequence. You can do this on-screen or with the Sequence docker. The 
Sequence Selected Color Blocks tool becomes available. Click to the invoke the dialog. 

 

Move colors up or down in the sequence via the ‘Move’ buttons, and click OK. Colors and 
component objects are sequenced in the selected color sequence. 
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Optimize color changes 

 

Use Edit Objects > Optimize Color Changes to optimize design by reducing color changes to a 
minimum, while maintaining color layers. 

It is important to be able to sequence objects by color. This reduces the number of potential color 
changes in a design. Use the docker to manually sequence objects of the same color. Alternatively, 
click the Optimize Color Changes button. This command optimizes production by reducing color 
changes to a minimum while maintaining color layers. 

 

In many cases you can rely on the software to work out the optimum stitching sequence for you. 
The example shows the results of color sequencing on the right - 3 color changes as opposed to the 
original 14. 

 

Don’t rely on automatic color change optimization as there may be instances where you want the 
same color to be stitched at different stages. 
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SPLIT OBJECTS 

The software lets you split branched objects – monograms, appliqués, lettering, etc – into their 
components. You can also cut shapes into smaller fragments which is especially useful for editing 
converted TrueType fonts. 

The design should be saved before you break it apart. Save to a different name so you can go 
back to the original compound object to edit if necessary. 

Break apart objects 

 

Use Edit Objects, Appliqué or Lettering / Monogramming > Break Apart to split composite 
objects - monograms, appliqués, lettering, etc - into components. Allows each to be edited 
individually. This tool is also available via Edit menu. 

 

Certain objects such as appliqué, are ‘compound’ objects and cannot be ungrouped in the normal 
way. Sometimes, you may want to edit components which cannot be done within the grouped 
compound object. For example, you may want to make edits to the various layers of appliqué such 
as the tackdown stitch, etc. Alternatively, you may want to sequence the stitching order of appliqué 
components. To perform such editing operations, compound objects need to be ‘broken apart’. Use 
Break Apart to split all composite objects - monograms, appliqués, lettering, etc - into components. 
The effect on these objects is similar to the ungrouping operation. However, once it is broken 
apart, it cannot be re-grouped as a compound object again. 

 Select the object to break apart – open-object appliqué, auto-appliqué, monogram, or 
lettering. The Break Apart command is activated. 

 
 Click Break Apart. The object is separated into its component source (primary) and any 

generated (secondary) objects. 
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 The operation ungroups monograms into component objects – a lettering object, ornaments 

(each ornament set remaining as a group) and borders (also grouped). See also Split lettering. 

 
 To modify individual objects – e.g. to change the stitching sequence of monogram borders – 

use the Sequence docker to ungroup objects and sequence. See also Sequence designs. 

When saved into earlier versions of the software, monograms, appliqués, and lettering may be 
subjected to Break Apart by default. 

 

 

http://www.embroideryhelp.net/display/HATCH/.Break+apart+lettering+v2.0
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Cut shapes manually 

 
Use Lettering / Monogramming or Edit Objects > Knife to cut objects along a digitized line, 
preserving stitch settings and colors. 

 
Use Edit Objects / Select > Reshape to reshape an object outline, stitch angles or enveloping. 

 

Depending on your product level, the Knife tool may be available in your Edit Objects toolbox. Use 
it to manually cut closed or block-digitized shapes into smaller fragments. It can, for instance, be 
useful when editing artwork converted to embroidery with auto-digitizing methods. 

 

The Knife tool has two modes of operation: 

 With nothing selected, it will cut all objects under the knife. 

 With selected objects, it will only cut those within the selection. 

Note that the Knife tool will cut both filled objects and outlines. This is often necessary when 
objects include an outline type of stitch which also needs to be cut. This is often the case, for 
example, where you want to make a split monogram. It also affects any object with a z-z underlay, 
blanket stitch, etc. It also affects stitch format designs that you may work with. 

 

Generally, auto-digitizing conversion problems can be fixed with a combination of Knife and 
Reshape tools. 

The Knife tool will also work with Satin, Zigzag, and Blanket outlines. It does not work with other 
outline types such as Run or Motif. 
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EDIT STITCHES 

With embroidery designs, stitches are 
automatically generated from design outlines 
and properties. This means you can scale, 
transform and reshape designs without 
affecting stitch density or quality. However, 
the software also lets you edit individual 
stitches. 

For example, you can insert stitches in an 
object to fill gaps, or move and delete 
individual or clusters of selected stitches. You 
may need to do this, for example, when 
working with ‘stitch files’ which do not 
contain design outline data. In essence, you 
simply select and manipulate stitches like any other object. 

Where possible though, edit object properties rather than individual stitches. All stitch edits are 
lost when an object is modified and regenerated. For that reason, stitch edits are mainly applied to 
stitch files rather than design files. 

Select stitches 

 
Use Edit Objects > Stitch Edit to place stitch cursor at selected insertion point. 

 

The Stitch Edit feature lets you select single stitches, several stitches, or a range of stitches by 
selecting their needle points. 

 Zoom in and display the needle points for easier selection. 

 Select the object and click Stitch Edit. 

 Select individual stitches in Stitch Edit mode by selecting their needle points. 

 The needle point and stitch colors change and the needle position marker moves to the 
selected stitch. All stitches after the needle position marker in the stitching sequence appear in 
black. 
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 To select multiple stitches, hold down <Shift> or <Ctrl> as you click. 

 Alternatively, drag a selection marquee around them. 

 
 Press <Delete> to eliminate unwanted stitches. 

 

Insert stitches 

You can insert stitches in an object to fill gaps. Inserted stitches are incorporated into the object. 
They will, however, be lost if the object’s stitches are regenerated. 

 Select a needlepoint. The needle point and stitch colors change and the needle position marker 
moves to the selected stitch. All stitches after the needle position marker in the stitching 
sequence appear in black. 

 Use the arrow keys to travel between stitches. 

 Move the mouse pointer where you want to insert the new stitch, and right-click. 

 
 Continue right-clicking as needed. 
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Move stitches 

You can move individual or groups of selected stitches. As always, if an object’s stitches are 
regenerated for any reason, all stitch editing functions are lost. 

 Zoom in, select the object and click Stitch Edit. 

 Select the stitches to move. 

 Drag them to a new position. The stitch shadow outline shows the new position. 

 

Select while traveling 

 
Use Edit Objects > Stitch Edit to place stitch cursor at selected insertion point. 

 

Use Travel > Select While Traveling to toggle on to select stitches, objects, or colors while 
traveling through a design. 

 

‘Traveling’ through a design is usually associated with checking the stitching sequence. However, 
you can also select objects as you travel. Switch to Stitch Edit mode. Then, with the Select While 
Traveling tool activated, use any of the Travel tools and as you move through design, objects are 
selected. See also View stitching sequence. 

 

http://www.embroideryhelp.net/display/HATCH/.Travel+through+designs+v2.0
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COPYRIGHT 

Copyright © 2018. Wilcom Pty Ltd, Wilcom International Pty Ltd. All Rights reserved. 

No parts of this publication or the accompanying software may be copied or distributed, transmitted, transcribed, 
stored in a retrieval system or translated into any human or computer language, in any form or by any means, 
electronic, mechanical, magnetic, manual, or otherwise, or disclosed to any third party without the express written 
permission of: 

Wilcom Pty Ltd. (A.B.N. 43 001 971 919) 
Level 3, 1-9 Glebe Point Rd, Glebe 
Sydney, New South Wales, 2037, Australia 
PO Box 1094, Broadway, NSW 2007 
Phone: +61 2 9578 5100 
Fax: +61 2 9578 5108 
Email: wilcom@wilcom.com 
Web: http://www.wilcom.com 

TrueView™ and Point & Stitch™ are trademarks of Wilcom Pty Ltd. Portions of the imaging technology of this 
Product are copyrighted by AccuSoft Corporation. The EPS File Import/Export Converter used in this Product is 
copyrighted by Access Softek, Inc. All rights reserved. 

Wilcom Pty Ltd makes no representation or warranties with respect to the contents of this publication and 
specifically disclaims any implied warranties of merchantable quality or fitness for any particular purpose. Further, 
Wilcom Pty Ltd reserves the right to revise this publication and to make changes in it from time to time without 
obligation of Wilcom Pty Ltd to notify any person or organization of such revisions or changes. 

The screen illustrations in this publication are intended as representations, not exact duplicates of screen layouts 
generated by the software. The samples used to illustrate software features and capabilities may not be exactly 
duplicable, depending on inclusions provided with your software model or product level. Some artwork for design 
samples is kindly provided by Digital Art Solutions. 

Subject to any warranties implied by law which are incapable of limitation or exclusion, the software is purchased 
‘as is’ without any warranty as to its performance, accuracy, freedom from error or to any results generated 
through its use and without any implied warranty of merchantability or of fitness for any particular purpose for 
which the software is being acquired. The purchaser relies on its own skill and judgement in selecting the software 
for its own use and assumes the entire risk as to the results and performance of the software. Wilcom Pty Ltd 
specifically does not warrant that the software will meet the purchaser’s requirements or operate without 
interruption or error. 
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