Select objects

The software provides various ways to select the objects that comprise an embroidery design. You can select all objects to modify the design as a whole, or individual objects for more precise modification.

On this page...


Use Select > Select Object to select an object or group. Or drag a selection marquee to select multiple enclosed objects or groups.

Use Select > Polygon Select to select an object or group by digitizing a polygon line around them.

 

 

Select with 'Select'

The Select tools provide various means for selecting objects including point and click, bounding box selection, and – in conjunction with Shift+Tab keys – first/last and next/previous object selection. You can also select all objects to apply changes to a whole design.

  • Use the drop arrow to select the tool you want to use.
  • The Select tool provides various means for selecting objects including point and click, bounding box selection, and – in conjunction with Shift+Tab keys – first/last and next/previous object selection. You can also select all objects to apply changes to a whole design.
  • To select all objects in a design, select Edit > Select All or press <Ctrl + A>.
  • To deselect, press <X> or <Esc>.
  • The simplest way to select objects is by pointing and clicking with the mouse with the Select tool activated. With <Shift> and <Ctrl> keys, you can select multiple objects.
  • To select an object which is behind another object, zoom in and click the outline. Alternatively, position the pointer over the object, hold down the <2> key, and click until the object is selected. Each click selects the next overlapping object.
  • With the Select tool activated, you can also select objects by dragging a bounding box around them
  • Use the Polygon Select tool to select an object or group by clicking reference points around them.

Use Travel > Select While Traveling to toggle on to select stitches, objects, or colors while traveling through a design.

Use Edit Objects > Stitch Edit to place stitch cursor at selected insertion point. Allows editing of individual stitches.

 

Select while traveling

Traveling through a design is usually associated with checking the stitching sequence. However, you can also select objects as you ‘travel’. With the Select While Traveling tool activated, use any of the Travel tools and as you move through design, objects are selected.

In order to select while traveling, you must be working in stitch edit mode. See Edit stitches.


Use Edit Objects > Resequence Manually to show or hide Resequence docker. Use it to resequence objects and color blocks in a design.

Select with 'Resequence'

The Resequence docker provides a sequential list of objects as digitized, grouped by ‘color block’. It stays on the design window as long as you need it and offers an easy way to select objects and view them. It is normally docked on the right of the design window but can be dragged to any position and resized as required.

  • Toggle between object view and color block view by clicking the 'Objects' button. In color mode, the docker displays a separate icon for each color block in the design, in order of stitching. In object mode, it displays a separate icon for each object in the design. 
  • Use the list to perform many object manipulations, including sequencing, editing, locking, hiding, etc.
  • To select a range of items, hold down <Shift> as you click.
  • To select multiple items, hold down <Ctrl> as you click.
  • To deselect all objects, click away from them or press <Esc>.
  • Right-click to access the popup menu.

.

Selection functions

Keyboard shortcuts are available for most selection functions:

To
Press

Choose Select tool

<O>

Select multiple objects

<Ctrl> + left-click
Select a range of objects<Shift> + left-click first and last objects
Select next object     <Tab>
Select previous object<Shift + Tab>
Add next object to selection<Ctrl + Tab>
Add previous object to selection<Ctrl + Shift + Tab>
Select all objects<Ctrl + A>
Deselect all objects<Esc> or <X>