Embroidery connections

Connectors link objects in a design. They can be run stitches or jumps. You can use automatic settings to generate connectors, trims and tie-offs, or add them manually. If you prefer to add tie-offs and trims as you digitize, you can turn off automatic connectors altogether.

The software also allows you to create ‘branched objects’. Selected objects are resequenced, connectors minimized, components grouped, and stitches regenerated. Underlay can be applied to all.

On this page...


Use View > Show Design to show or hide design elements. Click to open droplist of view settings.

Use Select > Reshape to adjust object outlines, stitch angles, start and end points, curved lines, etc.

View connectors

Turn on connectors via the Show Design droplist or press <Shift + C>. The triangle indicates a trim, while a dotted line indicates a jump. In TrueView, jumps do not appear.

When studying connectors, you may find that the distance between consecutive objects is not as close as it could be. To adjust connecting stitches, use Reshape to reset entry and exit points.

The Apply Closest Join feature allows you to (re-)apply closest join to selected objects after editing. The command is enabled when two or more embroidery objects are selected. See Closest joins.


Use Context > Always Tie-Off & Trim to trim connectors. When turned on, connectors will always be tied off and trimmed. Otherwise, the software will decide when to trim.

Use Edit Objects > Object Properties to preset properties or adjust them for selected objects.

Automatic connectors

The software generates connecting stitches both within and between objects, based on Object Properties. You can use the Always Tie-Off & Trim tool on the Context toolbar to force the use of trims when you don't want connecting stitches to appear. For instance, lettering objects often contain connecting stitches between letters. In the sample below, the first object uses default settings and includes connecting stitches between letters 'b_l_i_c_k'. The second object includes trims between each letter as indicated by the small triangles. The Always Tie-Off & Trim tool will appear on the Context toolbar whenever you choose one or more embroidery objects. See also View embroidery elements.

You can change connector settings for a whole design or selected objects. Sometimes, for instance, you may want to insert a jump as a connector between embroidery objects. The software inserts Tie-off and Trim functions which command the machine to cut the connecting thread. The easiest way to do so is to select the first object and click Always Tie-Off & Trim on the Context toolbar.

At other times, you may actually want the software to turn off Trims and Tie-offs for selected objects or for entire designs. For instance, if the connecting run is hidden beneath another object, it is more efficient to use a connecting run rather than a trim and tie-off. You can do this via the Object Properties > Stitching tab. The following settings apply selectively to tie-ins, tie-offs, and/or trims. They work both for selected objects and when digitizing new objects.

Setting Purpose
On, if next connector >= 2 mm When selected, automatic trims will be applied when digitizing. This setting can be turned on or off for selected objects. The 'Always Tie-off and Trim' icon on the Context toolbar is enabled but not activated.
Always

When selected, automatic trims will always be applied when digitizing or to selected objects. This setting is activated whenever the 'Always Tie-off and Trim' icon is activated.

Off

This has the effect of turning off trims when digitizing. The setting can be turned off for selected objects. When selected, the 'Always Tie-off and Trim' icon on the Context toolbar is greyed out.


Use Digitize / Auto-Digitize / Edit Objects > Branching to automatically sequence selected outlines for efficient stitchout.

Branching

Branching is an advanced feature which lets you digitize similar, overlapping objects – e.g. the fingers of a hand, sections of a custom letter – without having to think about the most efficient stitching sequence and joins. Apply the command to join selected objects to form a single compound object. Components are resequenced, connectors minimized, and stitches regenerated. All component objects are grouped and selectable as one.

 

.

Create branching

Apply Branching to selected objects. These become a single branched object.

  • Select the objects to sequence. Note any long connectors between objects.
  • Click Branching.
  • Digitize entry and exit points or press <Enter> twice to accept the defaults. Component objects are grouped and share the color of the first.
  • Travel through the object to check stitching. Note that objects are resequenced, connectors minimized, and stitches regenerated.

When the entry and exit point are the same, there are two layers of outline stitching. If they are different, the path between the entry and exit will have three layers. It is your choice whether to have the extra travel layer or a trim connection to the next object instead.

.

Branching works with most objects. Branched objects preserve their original settings while sharing the color of the first object in the sequence.

Use Edit Objects, Appliqué or Lettering / Monogramming > Break Apart to split composite objects - monograms, appliqués, lettering, etc - into components. Allows each to be edited individually. This tool is also available via Edit menu.

Edit branched objects

Branched objects remain editable. They can be reshaped. There is only one entry and one exit point, but all component objects have individual reshape points. The object properties of a compound object can be accessed and modified via the Object Properties dialog. If necessary, branched objects can be returned to their component objects using the Break Apart tool. See also Split objects.